Relatie niet automatisch ingevuld/toegekend ondanks actieregel



28 Jan 2015 20:42

Bij inlezen bestand worden relatie-namen die ik heb toegevoegd niet automatisch ingevuld/toegekend. Als ik achteraf op Wijzig regel klik dan wordt de relatie-naam echter wel automatisch toegekend. Heb de actieregel nagekeken en die klopt. Vraag me dus af waarom dit niet gelijk goed gaat bij het inlezen van het bestand.

2 Antwoorden
28 Jan 2015 20:42

Ik had hem gezien inderdaad. De relaties worden wel gevuld door de actieregels, maar de weergave wordt niet ververst na het inlezen; dit is een bug(je) in de laatste versie. Deze zal ik voor de komende release aanpassen.

12 Jul 2015 09:59

Hallo, ik evalueer op dit moment uw product en loop vermoedelijk tegen ditzelfde probleem aan. Ik heb alle transacties van de afgelopen 4 jaar geïmporteerd en ben ze nu aan het categoriseren. Inmiddels heb ik ongeveer 100 actieregels aangemaakt. Ik heb nog een berg transacties te gaan en merk dat bij een aantal de regels niet worden toegepast, terwijl de query wel overeenkomt. Als ik dan een transactie handmatig open, naar de bestaande regel ga en toepas, dan wordt de transactie wel toegekend.
Maar ook weer niet altijd. Soms zie je dat de transactie in het overzicht een post krijgt, maar als je vervolgens het detailvenster van de transactie sluit, verdwijnt de toekenning weer en is de transactie niet meer aan een post gekoppeld.
Heeft dit te maken met de bug waar u hierboven over spreekt?
 
Groet, Russell

20 Jul 2015 09:12

De bug hierboven is al enige tijd geleden opgelost, dus verwacht niet dat je daar tegenaan loopt. Ik ben me niet bewust van het niet werken van actieregels. Als je van een betreffende transactie in het detailvenster kijkt (dubbelklikt), zie je dan wat staan bij actieregels? Daar behoort op volgorde te staan welke actieregels van toepassing zijn op de transactie. Let op dat een actieregel niet voldoet als er 1 van de opgegeven criteria niet overeenkomt (het zijn allemaal “EN” criteria die je opgeeft).
Mocht je er hiermee niet uitkomen zou je dan van een specifiek geval een screenshot kunnen mailen naar info@penningmeester.net van de transactie en de actieregel die daarop van toepassing had moeten zijn?

18 Sep 2015 12:26

Beste Jochem,<br><br>Ondanks dat jij aangeeft dat het probleem opgelost zou moeten zijn, loop ook ik nog steeds tegen een actieregel probleem met relaties aan.<br><br>Om het probleem duidelijk te maken, heb ik hieronder e.e.a. stapsgewijs beschreven.Ik hoop dat dit duidelijk genoeg is, om het probleem te kunnen tackelen.<br><br>Voor zover ik heb kunnen constateren, maakt het niet uit wat voor waarden er voor criteria en invullen staan. Vanzelfsprekend moeten ze wel overeenkomen voor de betreffende transactie(s).<br><br>De Actieregel:<br>Criteria: Rekening, Af/bij, Omschrijving<br>In vullen: Post, Relatie<br><br>Uitvoeren VANUIT "Autopost regels beheren"<br>————————————————————<br>1. door middel van actieregel selecteren<br>- selecteer de actie regel.<br>- uitvoeren door knop "uitvoeren" links onderin scherm. Tevens "overschrijf bestaande transacties".<br><br>Resultaat:<br>Van de transacties is ALLEEN "post" juist ingevuld. Veld "relatie" is ongewijzigd.<br><br>2. door middel van dubbelklikken op actieregel en scherm "Actieregel bewerken".<br>- dubbelklikken op actieregel. (scherm "Actieregel bewerken" opent)<br>- uitvoeren door knop "aanmaken" en dan op knop “OK" te klikken. Tevens "overschrijf bestaande transacties".<br><br>Resultaat:<br>Van de betreffende transacties zijn zowel "post" en "relatie" juist ingevuld.<br><br>Uitvoeren VANUIT een transactie.<br>———————————————<br>1. door middel van dubbelklikken op een transactie.<br>- tabblad klikken waarin de bestaande autoregel staat.<br>- actieregel selecteren en bewerken/dubbelklikken. (scherm "Actieregel bewerken" opent)<br>- uitvoeren door knop "aanmaken" en daarna door op knop “OK" te klikken.<br>- tevens "overschrijf bestaande transacties" bijwerken.<br><br>Resultaat:<br>Zowel "post" en "relatie" zijn juist ingevuld.<br><br>Uitzondering:<br>De velden van de onderhavige transactie worden heel even juist ingevuld, maar zodra alles is uitgevoerd worden de oude waarden weer getoond.<br><br>Kort samen gevat:<br>- vanuit BEHEER: vullen van veld "relatie" gaat bij selecteren van actieregel in beheer, NIET goed.<br>- vanuit TRANSACTIE: vullen van velden "post" en "relatie" gaat vanuit het "actieregel bewerken" scherm voor de onderhavige transactie NIET goed.<br>(betreffend record "gelocked"??)<br><br>Hopelijk kan je hiermee wat ontdekken om het probleem op te lossen.