Foutmelding bij het maken van een rapport



7 Mar 2021 11:56

Ik heb deze vraag al een keer gesteld maar krijg geen antwoord. als ik een rapport wil maken krijg ik een foutmelding die luidt: Er is een fout opgetreden bij het genereren van het rapport¬† org.xml.sax.SAXParseExcecption;lineNumber: 33; columNumber: 47; The entity name must immediately follow the \’&\’ in the entity reference. Ik hoop dat dit snel kan worden opgelost, en dat u antwoord geeft.

7 Antwoorden
7 Mar 2021 11:57

Kan het zijn dat bij betreffende administratie een post is gebruikt met een speciaal karakter? een & of > teken?
Waarschijnlijk is het dan opgelost door die te hernoemen.

7 Mar 2021 12:14

Nou dat is het niet net alles nagekeken, blijf de foutmelding houden. als ik oke kli krijg ik ook hetvolgende te zien:
Navigatie naar de webpagina is geannuleerd
Mogelijke acties:
geef het adres opnieuw op.
Misschien helpt dit aan een oplossing?

7 Mar 2021 12:50

Is er dan misschien een relatie of groep in de post die dit teken bevat?

7 Mar 2021 20:29

Ook dat niet alles nagekeken. 

13 Mar 2021 13:50

Zou u mij anders het logbestand c:\penningmeester\penningmeester.log kunnen opsturen? Mogelijk dat ik daar nog in kan zien wat er misgaat.

14 Mar 2021 09:11

Ik denk dat ik de oorzaak ondertussen weet. Sinds versie 6.2.0.11 wordt ook de naam van de administratie in het rapport weergegeven. Als er een & teken in de administratienaam zit gaat dat mis bij het genereren van het rapport. Dit is opgelost in de komende versie van Penningmeester. Tot die tijd is een eventuele oplossing om speciale tekens in de naam van de administratie (mdb file) te verwijderen.

14 Mar 2021 19:31

Hoi Jochem,
ik heb de naam van mijn bestand aangepast en het werkt weer.

Bedankt